LAB 24 Static Route Load Balancing

LAB 24 Static Route Load Balancing


Assalamualaikum wr.wb

Selamat malam semua, pada malam ini saya akan membahas materi tentang load balance dicisco, sebelumnya kita sudah belajar materi tentang routing dan basic switching, jika belom melihat postingan sebelumnya, maka ada baiknya untuk melihat postingan sebelumnya. oke mari simak lebih lanjut untuk penjelasannya.

Load Balancing

Load Balancing adalah sebuah teknik untuk memanfaatkan dua link koneksi internet. oke yuk langsung saja ke lab nya saja, jika ada yang ingin ditanyakan bisa dikolom komentar ya. :v

Berikut topologi yang akan kita gunakan :


Mulai Ngelab

1. Pertama konfigurasikan ip address pada setiap interface sesuai dengan topologi diatas
R1#conf t
R1(config)#int s0/0
R1(config-if)#ip address 12.12.12.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#int s0/1
R1(config-if)#ip address 13.13.13.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#int f0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R2#conf t
R2(config)#int s0/0
R2(config-if)#ip add 12.12.12.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit

R2(config)#int s0/1
R2(config-if)#ip add 13.13.13.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit

R2(config)#int f0/0
R2(config-if)#ip add 192.168.2.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit

2. Setelah itu konfigurasi ip address pada setiap PC Client sesuai dengan topologi





3. Langkah selanjutnya kalian konfigurasi static route pada setiap routernya baik itu R1 maupun itu R2
R1(config)#ip route 192.168.2.0 255.255.255.0 12.12.12.2
R1(config)#ip route 192.168.2.0 255.255.255.0 13.13.13.2
R2(config)#ip route 192.168.1.0 255.255.255.0 12.12.12.1
R2(config)#ip route 192.168.1.0 255.255.255.0 13.13.13.1

Karena ada dua link seperti pada topologi maka kita buat dua static route juga. yaitu melewati ip 12.12.12.x/24 dan 13.13.13.x/24

4. Lakukan verifikasi table routing pada setiap router




Terlihat bahwa pada table routing sudah ada dua link yaitu link yang melalui ip 12.12.12.x dan link yang melalui 13.13.13.x. 

5. Terakhir coba lakukan traceroute untuk mengetest apakah load balancing ini sudah berjalan.




Terlihat bahwa kedua link tersebut digunakan secara bersamaan, maka konfigurasi load balancing static route sudah berhasil. mungkin itu saja yang bisa saya sampaikan semoga bisa bermanfaat, dan semoga postingan ini bernilai ibadah.

Wassalamualaikum wr.wb

LAB 23 Konfigurasi Default Route

LAB 23 Konfigurasi Default Route


Assalamualaikum wr.wb

Halo semua, kali ini saya akan melanjutkan materi routing yang sudah saya bahas dipostingan-postingan sebelumnya, pada postingan sebelumnya saya membahas materi tentang named static route yang digunakan untuk mendeskripsikan jalur routing. dan pada postingan kali ini saya akan membahas tentang default route pada cisco tentunya. mari simak lebih lanjut

Default Route

Default Route digunakan ketika kita tidak mengetahui ip destination (tujuan) biasanya digunakan untuk melakukan routing ke internet. jadi seolah-olah semua rute akan dianggap cocok dengan ip tujuan.

Oke lanjut, berikut topologi yang akan kita gunakan :


Mulai Ngelab

1. Pertama konfigurasikan ip address pada masing-masing interface sesuai topologi diatas 

R1(config)#int f0/0
R1(config-if)#ip add 12.12.12.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit

R1(config)#int f0/1
R1(config-if)#ip add 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R2(config)#int f0/0
R2(config-if)#ip add 12.12.12.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit

R2(config)#int f0/1
R2(config-if)#ip add 192.168.2.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit

2. Kemudian isi IP Address pada masing-masing laptop client



3. Kemudian lakukan konfigurasi default route pada setiap routernya
R1(config)#ip route 0.0.0.0 0.0.0.0 12.12.12.2

R2(config)#ip route 0.0.0.0 0.0.0.0 12.12.12.1

4. Lakukan verifikasi table routing pada setiap route apakah sudah ada rute komunikasi dengan client yang berada di R1 atau R2



Terlihat diatas, baik R1 dan R2 mereka sudah memiliki table routing untuk melakukan komunikasi antar client

Bisa juga dengan menggunakan show ip route static (untuk melihatkan table routing static)


5. Terakhir coba lakukan ping dari laptop 1 ke laptop 2 atau sebaliknya


Oke success, sekarang laptop 1 yang berada di R1 dan laptop 2 yang berada di R2 sudah bisa saling berkomunikasi. mungkin itu saja postingan kali ini, semoga bisa bermanfaat untuk kalian semua. dan semoga postingan ini bernilai ibadah.

Wassalamualaikum wr.wb

LAB 22 Named Static Route

LAB 22 Named Static Route


Assalamualaikum wr.wb

Selamat sore semuanya, hari ini saya akan melanjutkan lab-lab berikutnya tentang cisco, setelah kemaren kita sudah mempelajari konsep dasar dan basic konfigurasi dari setiap routing maka pada lab-lab selanjutnya saya akan sedikit berbagi materi yang masih menyangkut dengan materi routing static, ospf, eigrp dan lain-lain, tetapi dengan fungsi dan metode yang berbeda. oke untuk lebih lanjutnya mari simak lebih lanjut.

Lihat juga postingan sebelumnya :


Named Static Route

Named static route ini berfungsi ketika kita ingin mendeskripsikan jalur routing. hampir sama seperti kita mendeskripsikan interface. metode ini tidak support di cisco packet tracer maka saya membuat tutorial ini dengan GNS3. jika ada yang belum paham untuk memakai GNS3 bisa download panduannya disini

Oke lanjut ke lab nya berikut topologi yang akan kita gunakan :


Mulai Ngelab

1. Pertama konfigurasi ip address pada masing-masing interface sesuai ditopologi
R1(config)#interface f0/0
R1(config-if)#no shutdown
R1(config-if)#ip address 12.12.12.1 255.255.255.0
R1(config-if)#exit

R1(config)#int f0/1
R1(config-if)#no shutdown
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#exit
R2(config)#int f0/0
R2(config-if)#ip address 12.12.12.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit

R2(config)#int f0/1
R2(config-if)#no shutdown
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)#exit

2. Kedua konfigurasi ip address pada setiap VPCS nya sesuai topologi

PC-1


PC-2


3. Ketiga konfigurasi static route pada setiap route
R1(config)#ip route 192.168.2.0 255.255.255.0 12.12.12.2 name Melewati-R2

R2(config)#ip route 192.168.1.0 255.255.255.0 12.12.12.1 name Melewati-R1

Terlihat bahwa pada konfigurasi static route dengan named ini ada sedikit tambahan command dibaris akhirnya yang mendeskripsikan jalur atau rute untuk mencapai ke tujuannya.

4. Keempat, cek table routing pada router



Terlihat bahwa R1 dan R2 masing-masing sudah memiliki jalan untuk melakukan komunikasi antar clientnya.

5. Kelima Verfikasi pada setiap PC, pastikan dapat saling ping


Oke success, PC-1 dengan PC-2 sudah dapat saling berkomunikasi. mungkin itu saja yang bisa saya sampaikan, dan semoga bermanfaat. semoga postingan ini bernilai ibadah.

Wassalamualaikum wr.wb


LAB 21 Konfigurasi Redistribute Static Routing & EIGRP

LAB 21 Konfigurasi Redistribute Static Routing & EIGRP


Assalamualaikum wr.wb

Halo semua, kali ini saya akan melanjutkan materi dari postingan sebelumnya, masih tentang redistribute, sebelumnya kita sudah membahas materi redistribute dari static routing ke RIPV2 dan OSPF, kali ini kita akan membahas lanjutanya. mari simak lebih lanjut untuk konfigurasinya.


Apa Itu Redistribute.?

Redistribute adalah teknik menggabungkan protokol routing yang berbeda, tujuannya agar dapat saling berkomunikasi. jadi nantinya akan ada sebuah kasus dimana R1 menggunakan protokol routing static sementara R2 dan R3 akan menggunakan routing EIGRP, nantinya kita akan menghubungkan kedua protokol routing tersebut agar client nya bisa saling berkomunikasi.

Topologi
Mulai Ngelab

1. Tahap pertama konfigurasi ip address pada setiap routernya sesuai dengan topologi

R1(config)#int f0/0
R1(config-if)#no shutdown
R1(config-if)#ip address 12.12.12.1 255.255.255.252
R1(config-if)#exit
R1(config)#interface f0/1
R1(config-if)#no shutdown
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#exit
R2(config)#int f0/0
R2(config-if)#ip add 12.12.12.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#int f0/1
R2(config-if)#ip add 23.23.23.1 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit
R3(config)#int f0/0
R3(config-if)#ip add 23.23.23.2 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#int f0/1
R3(config-if)#ip add 192.168.2.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit

2. Setelah itu kita aktifkan protokol routing pada setiap routernya. ingat ya R1 kita setting routing static, R2 dan R3 nanti kita akan mensetting Routing EIGRP.


R1(config)#ip route 192.168.2.0 255.255.255.252 12.12.12.2 
R1(config)#ip route 23.23.23.0 255.255.255.252 12.12.12.2 
R2(config)#router eigrp 10
R2(config-router)#network 23.23.23.0
R2(config-router)#no auto-summary 
R2(config-router)#exit
R2(config)#ip route 192.168.1.0 255.255.255.0 12.12.12.1
R3(config)#router eigrp 10
R3(config-router)#network 192.168.2.0
R3(config-router)#network 23.23.23.0
R3(config-router)#no auto-summary 
R3(config-router)#exit

3.  Lakukan setting ip address pada setiap laptop clientnya




Lakukan verifikasi ping dari laptop 2 ke laptop 1 atau sebaliknya.



Hasilnya Destination host unreachable. kenapa.? karena protokol routing masing2 router berbeda, dan Laptop-2 yang berada di R3 belum memiliki rute menuju Laptop 1 yang berada di R1. agar kita tahu maka cek table routing pada R3 dengan perintah show ip route.



Terlihat bahwa R3 belum memiliki rute yang menuju Laptop-1 yang berada di R1.

4. Lakukan konfigurasi redistribute  pada R2 berikut perintahnya


R2(config)#router eigrp 10
R2(config-router)#redistribute static 
R2(config-router)#redistribute connected 
R2(config-router)#exit

Kemudian cek kembali table routing pada R3.


Terlihat bahwa table routing R3 sudah bertambah dan ada network 12.12.12.0 dan network 192.168.1.0

5. Lakukan verifikasi ulang, dari laptop 2 ke laptop 1 atau sebaliknya.

Dari Laptop 2 Ke Laptop 1

Dari Laptop 1 Ke Laptop 2

Oke keduanya sudah bisa berkomunikasi. saya rasa cukup untuk postingan hari ini, semoga bermanfaat dan semoga postingan ini bernilai ibadah bagi kita semua. admin pamit

Wassalamualaikum wr.wb

LAB 20 Konfigurasi Redistribute Static Routing & OSPF

LAB 20 Konfigurasi Redistribute Static Routing & OSPF


Assalamualaikum wr.wb

Halo semuanya, masih bersama saya, malam ini saya akan menemani kalian semuanya lewat postingan ini dan postingan malam ini kita masih membahas redistribute, sebelumnya kita sudah belajar mengkonfigurasi redistribute dari static routing ke ripv2. nah sekarang beda lagi. penasaran.? yuk mari simak postingan ini lebih lanjut.


Apa Itu Redistribute.?

Redistribute adalah teknik menggabungkan protokol routing yang berbeda, tujuannya agar dapat saling berkomunikasi. jadi nantinya akan ada sebuah kasus dimana R1 menggunakan protokol routing static sementara R2 dan R3 akan menggunakan routing OSPF, nantinya kita akan menghubungkan kedua protokol routing tersebut agar client nya bisa saling berkomunikasi.

Topologi

Mulai Ngelab

1. Seperti biasanya pertama tentukan kita harus konfigurasi ip address pada masing-masing router nya. berikut command nya. untuk ip address nya sesuai topologi ya.

R1(config)#int f0/0
R1(config-if)#no shutdown
R1(config-if)#ip address 12.12.12.1 255.255.255.252
R1(config-if)#exit
R1(config)#interface f0/1
R1(config-if)#no shutdown
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#exit
R2(config)#int f0/0
R2(config-if)#ip add 12.12.12.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#int f0/1
R2(config-if)#ip add 23.23.23.1 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit
R3(config)#int f0/0
R3(config-if)#ip add 23.23.23.2 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#int f0/1
R3(config-if)#ip add 192.168.2.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit

2. Setelah itu kita aktifkan protokol routing pada setiap routernya. ingat ya R1 kita setting routing static, R2 dan R3 nanti kita akan mensetting Routing OSPF.


R1(config)#ip route 192.168.2.0 255.255.255.252 12.12.12.2 
R1(config)#ip route 23.23.23.0 255.255.255.252 12.12.12.2 
R2(config)#router ospf 1
R2(config-router)#network 23.23.23.0 0.0.0.3 area 0
R2(config-router)#exit
R2(config)#ip route 192.168.1.0 255.255.255.0 12.12.12.1
R3(config)#router ospf 1
R3(config-router)#network 23.23.23.0 0.0.0.3 area 0
R3(config-router)#network 192.168.2.0 0.0.0.255 area 0
R3(config-router)#exit


3. Lakukan setting ip address pada setiap laptop clientnya




Lakukan verifikasi ping dari laptop 2 ke laptop 1 atau sebaliknya.



Hasilnya Destination host unreachable. kenapa.? karena protokol routing masing2 router berbeda, dan Laptop-2 yang berada di R3 belum memiliki rute menuju Laptop 1 yang berada di R1. oke buktikan dengan perintah show ip route.


Terlihat bahwa R3 belum memiliki rute yang menuju Laptop-1 yang berada di R1.

4. Lakukan konfigurasi redistribute ospf pada R2 berikut perintahnya



R2(config)#router ospf 1
R2(config-router)#redistribute static 
% Only classful networks will be redistributed
R2(config-router)#redistribute static subnets 
R2(config-router)#redistribute connected subnets 
R2(config-router)#exit

Diatas terlihat bahwa saat kita hanya mengetikan redistribute static ada sesuatu yang muncul Only classful networks will be redistributed, intinya kita harus menambahkan perintah subnets dibelakangnya. Kak Kenapa harus menggunakan perintah subnets, agar prefix yang masuk tidak classful.

5. Kemudian cek kembali table routing pada R3



Terlihat bahwa table routing R3 sudah bertambah dan ada network 12.12.12.0 dan network 192.168.1.0.

6. Lakukan verifikasi ping dari laptop 2 ke laptop 1



Oke success, jadi konsepnya sebenernya sama, tapi ada beberapa perbedaan di command nya saja. karena tujuan dari lab ini sudah terwujud. maka saya rasa cukup postingan nya. semoga bermanfaat dan semoga postingan ini bernilai ibadah buat kita semuanya.

Wassalamualaikum wr.wb

LAB 19 Konfigurasi Redistribution Static Routing & RIP V2

LAB 19 Redistribution Static Routing & RIPV2


Assalamualaikum wr.wb

Selamat malam semuanya, pada malam ini saya akan melanjutkan materi-materi cisco yang sebelumnya belum sempat saya tulis, karena sudah hampir 2 minggu ini ada project jadinya agak jarang nulis, kebetulan pulang cepet tadi dan saya sempatkan untuk menulis materi tentang redistribute pada cisco. untuk pembahasannya mari ikuti postingan ini sampai selesai.

Apa Itu Redistribute.?


Redistribute adalah teknik menggabungkan protokol routing yang berbeda, tujuannya agar
dapat saling berkomunikasi. jadi nantinya akan ada sebuah kasus dimana R1 menggunakan protokol routing static sementara R2 dan R3 akan menggunakan routing RIPV2, nantinya kita akan menghubungkan kedua protokol routing tersebut agar client nya bisa saling berkomunikasi.

Topologi


Mulai Ngelab

1. Petama kita konfigurasi IP pada semua router terlebih dahulu


R1(config)#int f0/0
R1(config-if)#no shutdown
R1(config-if)#ip address 12.12.12.1 255.255.255.252
R1(config-if)#exit
R1(config)#interface f0/1
R1(config-if)#no shutdown
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#exit
R2(config)#int f0/0
R2(config-if)#ip add 12.12.12.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#int f0/1
R2(config-if)#ip add 23.23.23.1 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit
R3(config)#int f0/0
R3(config-if)#ip add 23.23.23.2 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#int f0/1
R3(config-if)#ip add 192.168.2.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit

2. Setelah itu kita aktifkan protokol routing pada setiap routernya. ingat ya R1 kita setting routing static, R2 dan R3 nanti kita akan mensetting Routing RIP.


R1(config)#ip route 192.168.2.0 255.255.255.252 12.12.12.2
R1(config)#ip route 23.23.23.0 255.255.255.252 12.12.12.2
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 23.23.23.0
R2(config-router)#no auto-summary
R2(config-router)#exit
R2(config)#ip route 192.168.1.0 255.255.255.252 12.12.12.1
R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#network 23.23.23.0
R3(config-router)#network 192.168.2.0
R3(config-router)#no auto-summary
R3(config-router)#exit

3. Setting IP Address pada setiap Laptop Client




Lakukan verifikasi ping dari laptop 2 ke laptop 1 atau sebaliknya.



Hasilnya Destination host unreachable. kenapa.? karena protokol routing masing2 router berbeda, dan Laptop-2 yang berada di R3 belum memiliki rute menuju Laptop 1 yang berada di R1. oke buktikan dengan perintah show ip route.



Terlihat bahwa R3 belum memiliki rute yang menuju Laptop-1 yang berada di R1.

4. Lakukan konfigurasi redistribute pada R2, perintahnya seperti dibawah ini.


R2(config)#router rip
R2(config-router)#redistribute static

Sekarang coba cek kembali route yang ada di R3




Oke Static Routing 192.168.1.0 sudah ada. Tetapi network 12.12.12.0 belum terdaftar. Untuk mendaftarkannya jalankan perintah redistribute  connected. Network 12.12.12.0 belum terdaftar dikarenakan network ini bukan routing static dan statusnya adalah directly connected (terhubung langsung) antara R1 dengan R2. lalu gimana caranya agar network 12.12.12.0 ada ditable routing R3.? caranya adalah dengan menambahkan command dibawah ini.

R2(config)#router rip
R2(config-router)#redistribute connected 

Oke sekarang coba cek kembali table routing yang ada di R3


Network 12.12.12.0 sudah ada dan kita bisa lanjut ke tahap verifikasi.

5. Lakukan verifikasi ulang dari Laptop 2 ke Laptop 1




Nah kan awalnya hasilnya masih Destination host Unreachable ya. dan setelah dikonfigurasi redistribute maka client sudah bisa saling berkomunikasi. oke karena tujuan dari lab ini sudah tercapai maka kita akan akhiri dulu untuk postingan ini. semoga bermanfaat dan mohon maaf apabila ada salah pemahaman dalam materi ini. semoga postingan ini bernilai ibadah. 

Wassalamualaikum wr.wb

Panduan Memulai Belajar JNCIA untuk Pemula

Panduan Memulai Belajar JNCIA untuk Pemula


Assalamualaikum wr.wb

Selamat pagi semua. gimana kabarnya hari ini.? kali ini admin akan sharing tentang juniper. beberapa pemula biasanya bingung ketika ingin belajar juniper. jadi tulisan ini akan membahas bagaimana sih caranya Nge-LAB juniper, awalnya ngapain aja dan  nantinya ngapain aja. oke mari simak lebih lanjut.

Kenalan Sama Si Juniper 

Juniper adalah salah satu perusahaan produsen router di dunia  yang bermarkas di Sunnyvale, California. seperti cisco, Mikrotik dan lain-lain. Juniper sendiri memiliki beberapa produk yaitu switch, router dan perangkat security seperti firewall. 

Hampir Seluruh provider di Indonesia menggunakan perangkat juniper, seperti Indosat, Telkomsel, XL, dll. 

Alat dan Bahan Yang diperlukan.?

1. Vmware workstation ( bisa kalian download sendiri ya :v)
2. Olive Junos ( Download disini)
3. Named pipe TCP proxy (Download disini)

Penjelasan :

Vmware Workstation ini nantinya kita gunakan untuk menjalan sistem operasi dari perangkat juniper yaitu Junos, junos ini berbasis Unix FreeBSD.

Olive Junos ini adalah sistem operasi dari perangkat juniper tersebut. layaknya seperti IOS pada cisco dan RouterOS pada mikrotik.

Named pipe TCP proxy ini nantinya digunakan sebagai penghubung antara vmware dengan software remote yang ada dilaptop kita. jadi nantinya junos yang berada di vmware kita akan remote via software remote yaitu putty, secureCRT dan masih banyak lagi software lainnya.

Prepare LAB

Pastikan semua alat dan bahan yang dibutuhkan sudah kalian download.

1. Tahap pertama adalah buka vmware workstation kalian kemudian pilih file > Open


2. Cari lokasi tempat kalian menyimpan file junos olive yang sudah kalian download jika sudah ketemu klik open.


3. Setelah proses import selesai. kemudian akan muncul tampilan seperti dibawah ini dan masuk ke menu edit  virtual machine settings.


4. Fokus ke bagian serial port dan copykan teks yang ada di use named pipe, nantinya teks tersebut akan kita taruh di software TCP Named Pipe Proxy.


5. Jalankan Olive Junos nya


6. Langkah selanjutnya kalian buka software Named Pipe TCP proxy, copykan teks yang tadi ada di serial port pada Vmware, dan isikan port nya (untuk port nya bebas ya). kemudian klik add.


Jika sudah di add hasilnya seperti dibawah ini.


8. Kemudian buka software remote akses yang ada di laptop atau komputer kalian. isi seperi gambar dibawah ini

Connection type : telnet
Hostname / IP    : 127.0.0.1
Port                    : 8000 (port ini samakan dengan pengaturan yang ada di named pipe TCP)


Jika sudah selesai maka klik open. dan jika berhasil maka akan muncul tampilan login seperti dibawah ini

login : root
password : root123


Sampai disini bahan dulu ngelab kalian sudah bisa digunakan, untuk perintah dasarnya akan saya bahas dilain waktu. semoga postingan ini bermanfaat dan bernilai ibadah. 

Wassalamualaikum wr.wb